Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2025 - 00:16 CEST
Scheduled
We are performing some maintenance job to enhance system performance, increasing our scalability and reliability.
Some dashboard features may be temporarily unavailable or return occasional 500 errors, and AntiVPN connector checks may experience minor instability, increased latency.
Core services and edge network will remain fully operational. The maintenance timeframe may vary, and we will provide updates as needed.
Posted Jun 24, 2025 - 00:15 CEST
This scheduled maintenance affected: Services (Cloud Backend, Checkpoint API) and Websites (Customer Dashboard).